[APIM] Error when trying to setup micro-gw

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[APIM] Error when trying to setup micro-gw

Dinusha Senanayaka
Hi APIM team,

Executed following command as per  doc [2]  to build generated source and got error [1]. Do we need to include any libraries ? (using micro-gw alpha release).

micro-gw build -l marketing_store


[1]  could not find package wso2/gateway:*

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: [APIM] Error when trying to setup micro-gw

Dinusha Dissanayake
Hi Dinusha,

Can you check if micro-gw-resources/projects/<lableName>/target/ contains the relevant distribution and zip with the corresponding lable name?

I got the same error, which I think is expected ( please correct me if I am wrong), and yet I could see the relevant artifacts and run them without any issue.

Thanks,
DinushaD

On Tue, Jun 26, 2018 at 11:13 AM, Dinusha Senanayaka <[hidden email]> wrote:
Hi APIM team,

Executed following command as per  doc [2]  to build generated source and got error [1]. Do we need to include any libraries ? (using micro-gw alpha release).

micro-gw build -l marketing_store


[1]  could not find package wso2/gateway:*

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Dinusha Dissanayake
Software Engineer
WSO2 Inc 
Mobile: +94712939439


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: [APIM] Error when trying to setup micro-gw

Harsha Kumara-2
In reply to this post by Dinusha Senanayaka


On Tue, Jun 26, 2018 at 11:14 AM Dinusha Senanayaka <[hidden email]> wrote:
Hi APIM team,

Executed following command as per  doc [2]  to build generated source and got error [1]. Do we need to include any libraries ? (using micro-gw alpha release).

micro-gw build -l marketing_store


[1]  could not find package wso2/gateway:*
This is harmless. I believe this is because packages not in the ballerina central as build try to pull these packages.  Build command will execute fine and distribution should be created.


--
Harsha Kumara
Associate Technical Lead, WSO2 Inc.
Mobile: +94775505618
Blog:harshcreationz.blogspot.com

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: [APIM] Error when trying to setup micro-gw

Dinusha Senanayaka
Thanks Dinusha/Harsha. Build distribution has been created in target even that error was there. 

Regards,
Dinusha

On Tue, Jun 26, 2018 at 11:27 AM, Harsha Kumara <[hidden email]> wrote:


On Tue, Jun 26, 2018 at 11:14 AM Dinusha Senanayaka <[hidden email]> wrote:
Hi APIM team,

Executed following command as per  doc [2]  to build generated source and got error [1]. Do we need to include any libraries ? (using micro-gw alpha release).

micro-gw build -l marketing_store


[1]  could not find package wso2/gateway:*
This is harmless. I believe this is because packages not in the ballerina central as build try to pull these packages.  Build command will execute fine and distribution should be created.


--
Harsha Kumara
Associate Technical Lead, WSO2 Inc.
Mobile: +94775505618
Blog:harshcreationz.blogspot.com



--
Dinusha Dilrukshi
Technical Lead
WSO2 Inc.: http://wso2.com/
Mobile: +94764069991
Blog: http://dinushasblog.blogspot.com/

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev