EI 6.1.1 - Dev studio mediator project issues

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

EI 6.1.1 - Dev studio mediator project issues

Kasun Indrasiri-2
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: +1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: EI 6.1.1 - Dev studio mediator project issues

sohani
Hi Kasun,

Sure. will have a look


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : +94 716439774

On Wed, Jun 28, 2017 at 12:04 AM, Kasun Indrasiri <[hidden email]> wrote:
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: <a href="tel:+1%20650-450-2293" value="+16504502293" target="_blank">+1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: EI 6.1.1 - Dev studio mediator project issues

sohani
Reported the issue at [1] and will work on fixing it


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : +94 716439774

On Wed, Jun 28, 2017 at 8:15 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi Kasun,

Sure. will have a look


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 12:04 AM, Kasun Indrasiri <[hidden email]> wrote:
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: <a href="tel:+1%20650-450-2293" value="+16504502293" target="_blank">+1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/



_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: EI 6.1.1 - Dev studio mediator project issues

sohani
Hi All,

Based on the offline discussion had with Vijitha, shall we only have synapse-core (the latest version 2.1.7-wso2v15) and commons-logging? 

  <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v15</version>
    </dependency>

Please confirm.


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : +94 716439774

On Wed, Jun 28, 2017 at 8:31 AM, Sohani Weerasinghe <[hidden email]> wrote:
Reported the issue at [1] and will work on fixing it


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:15 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi Kasun,

Sure. will have a look


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 12:04 AM, Kasun Indrasiri <[hidden email]> wrote:
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: <a href="tel:+1%20650-450-2293" value="+16504502293" target="_blank">+1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/




_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: EI 6.1.1 - Dev studio mediator project issues

Isuru Udana
Hi Sohani,

We also need to include axis2 kernel (this is to get access to axis2 message context)

Thanks.

On Thu, Jun 29, 2017 at 10:45 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi All,

Based on the offline discussion had with Vijitha, shall we only have synapse-core (the latest version 2.1.7-wso2v15) and commons-logging? 

  <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v15</version>
    </dependency>

Please confirm.


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:31 AM, Sohani Weerasinghe <[hidden email]> wrote:
Reported the issue at [1] and will work on fixing it


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:15 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi Kasun,

Sure. will have a look


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 12:04 AM, Kasun Indrasiri <[hidden email]> wrote:
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: <a href="tel:+1%20650-450-2293" value="+16504502293" target="_blank">+1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/






--
Isuru Udana
Senior Technical Lead
WSO2 Inc.; http://wso2.com
email: [hidden email] cell: +94 77 3791887
blog: http://mytecheye.blogspot.com/

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: EI 6.1.1 - Dev studio mediator project issues

sohani


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : +94 716439774

On Thu, Jun 29, 2017 at 11:00 AM, Isuru Udana <[hidden email]> wrote:
Hi Sohani,

We also need to include axis2 kernel (this is to get access to axis2 message context)

Thanks Isuru, will test and add that as well.  

Thanks.

On Thu, Jun 29, 2017 at 10:45 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi All,

Based on the offline discussion had with Vijitha, shall we only have synapse-core (the latest version 2.1.7-wso2v15) and commons-logging? 

  <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v15</version>
    </dependency>

Please confirm.


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:31 AM, Sohani Weerasinghe <[hidden email]> wrote:
Reported the issue at [1] and will work on fixing it


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:15 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi Kasun,

Sure. will have a look


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 12:04 AM, Kasun Indrasiri <[hidden email]> wrote:
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: <a href="tel:+1%20650-450-2293" value="+16504502293" target="_blank">+1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/






--
Isuru Udana
Senior Technical Lead
WSO2 Inc.; http://wso2.com
email: [hidden email] cell: <a href="tel:077%20379%201887" value="+94773791887" target="_blank">+94 77 3791887
blog: http://mytecheye.blogspot.com/


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: EI 6.1.1 - Dev studio mediator project issues

sohani
Hi Kasun,

This is fixed at [1] and will be available in the next EI tooling release


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : +94 716439774

On Thu, Jun 29, 2017 at 11:15 AM, Sohani Weerasinghe <[hidden email]> wrote:


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Thu, Jun 29, 2017 at 11:00 AM, Isuru Udana <[hidden email]> wrote:
Hi Sohani,

We also need to include axis2 kernel (this is to get access to axis2 message context)

Thanks Isuru, will test and add that as well.  

Thanks.

On Thu, Jun 29, 2017 at 10:45 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi All,

Based on the offline discussion had with Vijitha, shall we only have synapse-core (the latest version 2.1.7-wso2v15) and commons-logging? 

  <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v15</version>
    </dependency>

Please confirm.


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:31 AM, Sohani Weerasinghe <[hidden email]> wrote:
Reported the issue at [1] and will work on fixing it


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 8:15 AM, Sohani Weerasinghe <[hidden email]> wrote:
Hi Kasun,

Sure. will have a look


Thanks,
Sohani Weerasinghe
Senior Software Engineer
WSO2, Inc: http://wso2.com

Mobile  : <a href="tel:071%20643%209774" value="+94716439774" target="_blank">+94 716439774

On Wed, Jun 28, 2017 at 12:04 AM, Kasun Indrasiri <[hidden email]> wrote:
Hi, 

When creating the mediator project, there are a bunch of unnecessary dependencies added to pom and most of the dependencies are way too old. Can we please review this and fix, please. 



  <dependencies>
    <dependency>
      <groupId>commons-codec.wso2</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.httpcomponents.wso2</groupId>
      <artifactId>httpcore</artifactId>
      <version>4.3.3.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.woden.wso2</groupId>
      <artifactId>woden</artifactId>
      <version>1.0.0.M9-wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.commons-httpclient</groupId>
      <artifactId>commons-httpclient</artifactId>
      <version>3.1.0.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>wsdl4j.wso2</groupId>
      <artifactId>wsdl4j</artifactId>
      <version>1.6.2.wso2v4</version>
    </dependency>
    <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.1.1</version>
    </dependency>
    <dependency>
      <groupId>commons-io.wso2</groupId>
      <artifactId>commons-io</artifactId>
      <version>2.4.0.wso2v1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.synapse</groupId>
      <artifactId>synapse-core</artifactId>
      <version>2.1.7-wso2v7</version>
    </dependency>
    <dependency>
      <groupId>org.apache.ws.commons.schema.wso2</groupId>
      <artifactId>XmlSchema</artifactId>
      <version>1.4.7.wso2v3</version>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs.wso2</groupId>
      <artifactId>geronimo-stax-api_1.0_spec</artifactId>
      <version>1.0.1.wso2v2</version>
    </dependency>
    <dependency>
      <groupId>org.wso2.orbit.org.apache.neethi</groupId>
      <artifactId>neethi</artifactId>
      <version>2.0.4.wso2v5</version>
    </dependency>
  </dependencies>

--
Kasun Indrasiri
Director - Integration Architecture
WSO2, Inc.; http://wso2.com
lean.enterprise.middleware

cell: <a href="tel:+1%20650-450-2293" value="+16504502293" target="_blank">+1 650 450 2293
Blog : http://kasunpanorama.blogspot.com/






--
Isuru Udana
Senior Technical Lead
WSO2 Inc.; http://wso2.com
email: [hidden email] cell: <a href="tel:077%20379%201887" value="+94773791887" target="_blank">+94 77 3791887
blog: http://mytecheye.blogspot.com/



_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev