Error when running the newest build of MB-4

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Error when running the newest build of MB-4

Riyafa Abdul Hameed-2
Hi,

I built MB-4 from the 4.x.x branch of product-mb[1] and ran it by extracting 'wso2mb-4.0.0-SNAPSHOT.zip' from ''/product-mb/product/target'. I get the following error during execution of carbon.sh from the bin folder:
ERROR {org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent} - Could not initialize carbon deployment engine org.wso2.carbon.deployment.engine.exception.DeploymentEngineException: Cannot find repository : /home/riyafa/Documents/Workspace/product-mb/product/target/wso2mb-4.0.0-SNAPSHOT/deployment
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngine.start(DeploymentEngine.java:103)
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent.onAllRequiredCapabilitiesAvailable(DeploymentEngineListenerComponent.java:212)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.lambda$notifySatisfiableComponents$51(StartupComponentManager.java:238)
    at java.util.ArrayList.forEach(ArrayList.java:1249)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.notifySatisfiableComponents(StartupComponentManager.java:224)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupOrderResolver$1.run(StartupOrderResolver.java:204)
    at java.util.TimerThread.mainLoop(Timer.java:555)
    at java.util.TimerThread.run(Timer.java:505)

The current product-mb is written over C5 and I am not sure if it's an issue with C5. When I create a deployment folder in the wso2mb-4.0.0-SNAPSHOT folder and rerun product-mb the error goes away. Any highlight on the above issue would be of help.

Thank you.
Riyafa


[1] https://github.com/wso2/product-mb/tree/4.x.x/product

--
Riyafa Abdul Hameed
Software Engineer, WSO2 Lanka (Pvt) Ltd

Email: [hidden email]
Website: https://riyafa.wordpress.com/

  

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Error when running the newest build of MB-4

Pamod Sylvester
(+) KasunG

On Wed, May 31, 2017 at 9:27 AM, Riyafa Abdul Hameed <[hidden email]> wrote:
Hi,

I built MB-4 from the 4.x.x branch of product-mb[1] and ran it by extracting 'wso2mb-4.0.0-SNAPSHOT.zip' from ''/product-mb/product/target'. I get the following error during execution of carbon.sh from the bin folder:
ERROR {org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent} - Could not initialize carbon deployment engine org.wso2.carbon.deployment.engine.exception.DeploymentEngineException: Cannot find repository : /home/riyafa/Documents/Workspace/product-mb/product/target/wso2mb-4.0.0-SNAPSHOT/deployment
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngine.start(DeploymentEngine.java:103)
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent.onAllRequiredCapabilitiesAvailable(DeploymentEngineListenerComponent.java:212)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.lambda$notifySatisfiableComponents$51(StartupComponentManager.java:238)
    at java.util.ArrayList.forEach(ArrayList.java:1249)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.notifySatisfiableComponents(StartupComponentManager.java:224)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupOrderResolver$1.run(StartupOrderResolver.java:204)
    at java.util.TimerThread.mainLoop(Timer.java:555)
    at java.util.TimerThread.run(Timer.java:505)

The current product-mb is written over C5 and I am not sure if it's an issue with C5. When I create a deployment folder in the wso2mb-4.0.0-SNAPSHOT folder and rerun product-mb the error goes away. Any highlight on the above issue would be of help.

Thank you.
Riyafa


[1] https://github.com/wso2/product-mb/tree/4.x.x/product

--
Riyafa Abdul Hameed
Software Engineer, WSO2 Lanka (Pvt) Ltd

Email: [hidden email]
Website: https://riyafa.wordpress.com/

  

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Pamod Sylvester 
WSO2 Inc.; http://wso2.com
cell: +94 77 7779495

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Error when running the newest build of MB-4

Gihan Anuruddha
Hi,

This is a know issue. Can you please create an issue in here[1].


Regards,
Gihan

On Wed, May 31, 2017 at 9:32 AM, Pamod Sylvester <[hidden email]> wrote:
(+) KasunG

On Wed, May 31, 2017 at 9:27 AM, Riyafa Abdul Hameed <[hidden email]> wrote:
Hi,

I built MB-4 from the 4.x.x branch of product-mb[1] and ran it by extracting 'wso2mb-4.0.0-SNAPSHOT.zip' from ''/product-mb/product/target'. I get the following error during execution of carbon.sh from the bin folder:
ERROR {org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent} - Could not initialize carbon deployment engine org.wso2.carbon.deployment.engine.exception.DeploymentEngineException: Cannot find repository : /home/riyafa/Documents/Workspace/product-mb/product/target/wso2mb-4.0.0-SNAPSHOT/deployment
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngine.start(DeploymentEngine.java:103)
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent.onAllRequiredCapabilitiesAvailable(DeploymentEngineListenerComponent.java:212)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.lambda$notifySatisfiableComponents$51(StartupComponentManager.java:238)
    at java.util.ArrayList.forEach(ArrayList.java:1249)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.notifySatisfiableComponents(StartupComponentManager.java:224)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupOrderResolver$1.run(StartupOrderResolver.java:204)
    at java.util.TimerThread.mainLoop(Timer.java:555)
    at java.util.TimerThread.run(Timer.java:505)

The current product-mb is written over C5 and I am not sure if it's an issue with C5. When I create a deployment folder in the wso2mb-4.0.0-SNAPSHOT folder and rerun product-mb the error goes away. Any highlight on the above issue would be of help.

Thank you.
Riyafa


[1] https://github.com/wso2/product-mb/tree/4.x.x/product

--
Riyafa Abdul Hameed
Software Engineer, WSO2 Lanka (Pvt) Ltd

Email: [hidden email]
Website: https://riyafa.wordpress.com/

  

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Pamod Sylvester 
WSO2 Inc.; http://wso2.com
cell: <a href="tel:077%20777%209495" value="+94777779495" target="_blank">+94 77 7779495

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
W.G. Gihan Anuruddha
Associate Technical Lead | WSO2, Inc.

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Error when running the newest build of MB-4

Niranjan Karunanandham
Hi Riyafa,

This issue is happening because the deployment folder is not present in the product. As a workaround you can create it using the product repo bin.xml. Can you create a git issue for this in the carbon-deployment repo? The fix is to create the folder when the feature is installed.

Regards,
Nira

On Wed, May 31, 2017 at 10:54 AM, Gihan Anuruddha <[hidden email]> wrote:
Hi,

This is a know issue. Can you please create an issue in here[1].


Regards,
Gihan

On Wed, May 31, 2017 at 9:32 AM, Pamod Sylvester <[hidden email]> wrote:
(+) KasunG

On Wed, May 31, 2017 at 9:27 AM, Riyafa Abdul Hameed <[hidden email]> wrote:
Hi,

I built MB-4 from the 4.x.x branch of product-mb[1] and ran it by extracting 'wso2mb-4.0.0-SNAPSHOT.zip' from ''/product-mb/product/target'. I get the following error during execution of carbon.sh from the bin folder:
ERROR {org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent} - Could not initialize carbon deployment engine org.wso2.carbon.deployment.engine.exception.DeploymentEngineException: Cannot find repository : /home/riyafa/Documents/Workspace/product-mb/product/target/wso2mb-4.0.0-SNAPSHOT/deployment
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngine.start(DeploymentEngine.java:103)
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent.onAllRequiredCapabilitiesAvailable(DeploymentEngineListenerComponent.java:212)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.lambda$notifySatisfiableComponents$51(StartupComponentManager.java:238)
    at java.util.ArrayList.forEach(ArrayList.java:1249)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.notifySatisfiableComponents(StartupComponentManager.java:224)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupOrderResolver$1.run(StartupOrderResolver.java:204)
    at java.util.TimerThread.mainLoop(Timer.java:555)
    at java.util.TimerThread.run(Timer.java:505)

The current product-mb is written over C5 and I am not sure if it's an issue with C5. When I create a deployment folder in the wso2mb-4.0.0-SNAPSHOT folder and rerun product-mb the error goes away. Any highlight on the above issue would be of help.

Thank you.
Riyafa


[1] https://github.com/wso2/product-mb/tree/4.x.x/product

--
Riyafa Abdul Hameed
Software Engineer, WSO2 Lanka (Pvt) Ltd

Email: [hidden email]
Website: https://riyafa.wordpress.com/

  

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Pamod Sylvester 
WSO2 Inc.; http://wso2.com
cell: <a href="tel:077%20777%209495" value="+94777779495" target="_blank">+94 77 7779495

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
W.G. Gihan Anuruddha
Associate Technical Lead | WSO2, Inc.



--

Niranjan Karunanandham
Associate Technical Lead - WSO2 Inc.
WSO2 Inc.: http://www.wso2.com


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Error when running the newest build of MB-4

Riyafa Abdul Hameed-2
Hi All,

For the moment we will create the folder by adding it to the bin.xml of MB-4. Also I have created an issue regarding this:
https://github.com/wso2/carbon-deployment/issues/261

Thank you.
Riyafa

On Wed, May 31, 2017 at 10:58 AM, Niranjan Karunanandham <[hidden email]> wrote:
Hi Riyafa,

This issue is happening because the deployment folder is not present in the product. As a workaround you can create it using the product repo bin.xml. Can you create a git issue for this in the carbon-deployment repo? The fix is to create the folder when the feature is installed.

Regards,
Nira

On Wed, May 31, 2017 at 10:54 AM, Gihan Anuruddha <[hidden email]> wrote:
Hi,

This is a know issue. Can you please create an issue in here[1].


Regards,
Gihan

On Wed, May 31, 2017 at 9:32 AM, Pamod Sylvester <[hidden email]> wrote:
(+) KasunG

On Wed, May 31, 2017 at 9:27 AM, Riyafa Abdul Hameed <[hidden email]> wrote:
Hi,

I built MB-4 from the 4.x.x branch of product-mb[1] and ran it by extracting 'wso2mb-4.0.0-SNAPSHOT.zip' from ''/product-mb/product/target'. I get the following error during execution of carbon.sh from the bin folder:
ERROR {org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent} - Could not initialize carbon deployment engine org.wso2.carbon.deployment.engine.exception.DeploymentEngineException: Cannot find repository : /home/riyafa/Documents/Workspace/product-mb/product/target/wso2mb-4.0.0-SNAPSHOT/deployment
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngine.start(DeploymentEngine.java:103)
    at org.wso2.carbon.deployment.engine.internal.DeploymentEngineListenerComponent.onAllRequiredCapabilitiesAvailable(DeploymentEngineListenerComponent.java:212)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.lambda$notifySatisfiableComponents$51(StartupComponentManager.java:238)
    at java.util.ArrayList.forEach(ArrayList.java:1249)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupComponentManager.notifySatisfiableComponents(StartupComponentManager.java:224)
    at org.wso2.carbon.kernel.internal.startupresolver.StartupOrderResolver$1.run(StartupOrderResolver.java:204)
    at java.util.TimerThread.mainLoop(Timer.java:555)
    at java.util.TimerThread.run(Timer.java:505)

The current product-mb is written over C5 and I am not sure if it's an issue with C5. When I create a deployment folder in the wso2mb-4.0.0-SNAPSHOT folder and rerun product-mb the error goes away. Any highlight on the above issue would be of help.

Thank you.
Riyafa


[1] https://github.com/wso2/product-mb/tree/4.x.x/product

--
Riyafa Abdul Hameed
Software Engineer, WSO2 Lanka (Pvt) Ltd

Email: [hidden email]
Website: https://riyafa.wordpress.com/

  

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Pamod Sylvester 
WSO2 Inc.; http://wso2.com
cell: <a href="tel:077%20777%209495" value="+94777779495" target="_blank">+94 77 7779495

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
W.G. Gihan Anuruddha
Associate Technical Lead | WSO2, Inc.



--

Niranjan Karunanandham
Associate Technical Lead - WSO2 Inc.
WSO2 Inc.: http://www.wso2.com




--
Riyafa Abdul Hameed
Software Engineer, WSO2 Lanka (Pvt) Ltd

Email: [hidden email]
Website: https://riyafa.wordpress.com/

  

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev