Exception in ESB 5.0.0 while creating an API.

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Exception in ESB 5.0.0 while creating an API.

Piriya Sivalingam
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : +94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Exception in ESB 5.0.0 while creating an API.

Mushthaq Rumy
Hi Pririya,

Seems like the operation you use is an incorrect operation. Was this working fine in SOAPUI? Could you please check if "readNinewells" is the correct operation?

Thanks & Regards,
Mushthaq

On Sat, Nov 11, 2017 at 11:59 PM, Piriya Sivalingam <[hidden email]> wrote:
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Exception in ESB 5.0.0 while creating an API.

Piriya Sivalingam
Hi Mushthaq,

I tried the same operation in SOAPUI and it works fine. "readNinewells" is a correct operation. 

Thanks.  

On Sun, Nov 12, 2017 at 12:55 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Pririya,

Seems like the operation you use is an incorrect operation. Was this working fine in SOAPUI? Could you please check if "readNinewells" is the correct operation?

Thanks & Regards,
Mushthaq

On Sat, Nov 11, 2017 at 11:59 PM, Piriya Sivalingam <[hidden email]> wrote:
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : +94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Exception in ESB 5.0.0 while creating an API.

Mushthaq Rumy
Hi Piriya,

Can you attach the proxy WSDL file?

Thanks & Regards,
Mushthaq

On Sun, Nov 12, 2017 at 10:53 AM, Piriya Sivalingam <[hidden email]> wrote:
Hi Mushthaq,

I tried the same operation in SOAPUI and it works fine. "readNinewells" is a correct operation. 

Thanks.  

On Sun, Nov 12, 2017 at 12:55 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Pririya,

Seems like the operation you use is an incorrect operation. Was this working fine in SOAPUI? Could you please check if "readNinewells" is the correct operation?

Thanks & Regards,
Mushthaq

On Sat, Nov 11, 2017 at 11:59 PM, Piriya Sivalingam <[hidden email]> wrote:
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Exception in ESB 5.0.0 while creating an API.

Piriya Sivalingam
I am attaching the WSDL of my proxy service.



On Sun, Nov 12, 2017 at 11:44 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Piriya,

Can you attach the proxy WSDL file?

Thanks & Regards,
Mushthaq

On Sun, Nov 12, 2017 at 10:53 AM, Piriya Sivalingam <[hidden email]> wrote:
Hi Mushthaq,

I tried the same operation in SOAPUI and it works fine. "readNinewells" is a correct operation. 

Thanks.  

On Sun, Nov 12, 2017 at 12:55 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Pririya,

Seems like the operation you use is an incorrect operation. Was this working fine in SOAPUI? Could you please check if "readNinewells" is the correct operation?

Thanks & Regards,
Mushthaq

On Sat, Nov 11, 2017 at 11:59 PM, Piriya Sivalingam <[hidden email]> wrote:
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : +94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev

NinewellsProxyService1.wsdl (24K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Exception in ESB 5.0.0 while creating an API.

Piriya Sivalingam
I am attaching the WSDL of my deployed backend service.



On Sun, Nov 12, 2017 at 11:47 AM, Piriya Sivalingam <[hidden email]> wrote:
I am attaching the WSDL of my proxy service.



On Sun, Nov 12, 2017 at 11:44 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Piriya,

Can you attach the proxy WSDL file?

Thanks & Regards,
Mushthaq

On Sun, Nov 12, 2017 at 10:53 AM, Piriya Sivalingam <[hidden email]> wrote:
Hi Mushthaq,

I tried the same operation in SOAPUI and it works fine. "readNinewells" is a correct operation. 

Thanks.  

On Sun, Nov 12, 2017 at 12:55 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Pririya,

Seems like the operation you use is an incorrect operation. Was this working fine in SOAPUI? Could you please check if "readNinewells" is the correct operation?

Thanks & Regards,
Mushthaq

On Sat, Nov 11, 2017 at 11:59 PM, Piriya Sivalingam <[hidden email]> wrote:
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : +94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev

NinewellsPatientService.wsdl (28K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Exception in ESB 5.0.0 while creating an API.

Piriya Sivalingam
Hi,

I think its something similar to [1] and according to that I managed to resolve it by adding a dummy header.

[1] [Dev] Exception with header

Thanks,
Piriya

On Sun, Nov 12, 2017 at 12:27 PM, Piriya Sivalingam <[hidden email]> wrote:
I am attaching the WSDL of my deployed backend service.



On Sun, Nov 12, 2017 at 11:47 AM, Piriya Sivalingam <[hidden email]> wrote:
I am attaching the WSDL of my proxy service.



On Sun, Nov 12, 2017 at 11:44 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Piriya,

Can you attach the proxy WSDL file?

Thanks & Regards,
Mushthaq

On Sun, Nov 12, 2017 at 10:53 AM, Piriya Sivalingam <[hidden email]> wrote:
Hi Mushthaq,

I tried the same operation in SOAPUI and it works fine. "readNinewells" is a correct operation. 

Thanks.  

On Sun, Nov 12, 2017 at 12:55 AM, Mushthaq Rumy <[hidden email]> wrote:
Hi Pririya,

Seems like the operation you use is an incorrect operation. Was this working fine in SOAPUI? Could you please check if "readNinewells" is the correct operation?

Thanks & Regards,
Mushthaq

On Sat, Nov 11, 2017 at 11:59 PM, Piriya Sivalingam <[hidden email]> wrote:
Hi,

I am creating an API in ESB 5.0.0 for GET Resource, where I have a secured SOAP backend service. Below is my synapse configuration of the API. I find some error logged in the console.

<?xml version="1.0" encoding="UTF-8"?>
     name="PatientAPI"
     context="/patientapi">
   <resource methods="GET" uri-template="/{patientId}">
      <inSequence>
         <header name="Authorization"
                 scope="transport"
                 value="Basic cGlyaXlhOnBpcml5YTEyMw=="/>
         <payloadFactory media-type="xml">
            <format>
               <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                 xmlns:ser="http://service.sample.ninewells.com">
                  <soapenv:Header/>
                  <soapenv:Body>
                     <ser:readNinewells>
                        <ser:patientId>1111</ser:patientId>
                     </ser:readNinewells>
                  </soapenv:Body>
               </soapenv:Envelope>
            </format>
            <args>
               <arg value="1990"/>
            </args>
         </payloadFactory>
         <header name="Action" value="urn:readNinewells"/>
         <property name="SOAPAction" value="urn:readNinewells" scope="transport"/>
         <property name="messageType"
                   value="application/soap+xml"
                   scope="axis2"
                   type="STRING"/>
         <send>
            <endpoint>
               <address uri="https://xxxx.xx.xx.xx:xxx3/services/NinewellsPatientService"
                        format="soap11"/>
            </endpoint>
         </send>
      </inSequence>
      <outSequence>
         <property name="messageType"
                   value="application/json"
                   scope="axis2"
                   type="STRING"/>
         <send/>
      </outSequence>
   </resource>
</api>

There is a 500 Internal Server Error logged in the console.

Below is the exception found.
{"faultstring":"The endpoint reference (EPR) for the Operation not found is /services/DurdansPatientService and the WSA Action = null. If this EPR was previously reachable, please contact the server administrator."}

Highly appreciate your advice on this.

Thanks.

--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Mushthaq Rumy
Software Engineer
Mobile : <a href="tel:%2B94%20%280%29%20773%20451194" value="+94773451194" target="_blank">+94 (0) 779 492140
Email : [hidden email]
WSO2, Inc.; http://wso2.com/
lean . enterprise . middleware.




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : <a href="tel:+94%2077%20846%202039" value="+94778462039" target="_blank">+94 77 8462039

http://wso2.com/signature




--
Regards,
Piriya Sivalingam
Software Engineer - Support Team
WSO2
Mobile : +94 77 8462039

http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev