[Fwd: Re: login into esb v.1.6 failed]

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Fwd: Re: login into esb v.1.6 failed]

Jens Goldhammer
FYI

Hello Ruwan,

I have tested it with 4 different browsers (firefox2 and 3b2, internet
explorer 7, opera 9.25)!
The alert works in all browsers, but the login does not work :-((

I have unzipped the distribution again and start the esb.
Wow, now it works!!

The difference to my previous instance of the esb is that I haven´t
change the ports.
in axis2.xml:
change port for http from 8080 to 8280

in server.xml:
change port for adminconsole from 9443 to 9447

I have changed the prots also with the new unzipped esb, but I still
works. I don´t understand that!!
Do you have any idea?
Jens


Ruwan Linton schrieb:

> Jens,
>
> It seems something wrong with the browser, could you please try after
> restarting the browser, (You need to enable Java Script)
>
> You could paste the following line on the navigation bar of firefox
> and see whether java script is working properly. If there is an alert
> saying "test" it is working???
>
> javascript:alert("test");
>
> Thanks,
> Ruwan
>
> Jens Goldhammer wrote:
>> Hello Ruwan,
>> I have debugged the javascript function with the fireBug-extension
>> (firefox)
>>
>> *Header*
>>
>> Response Headers
>> Server     Apache-Coyote/1.1
>> Content-Type     multipart/related;
>> boundary=MIMEBoundaryurn_uuid_1FBBB5D851EFDB4D6F1202148138496;
>> type="application/xop+xml";
>> start="0.urn:uuid:[hidden email]";
>> start-info="text/xml"
>> Transfer-Encoding     chunked
>> Date     Mon, 04 Feb 2008 18:02:18 GMT
>> X-lori-time-2     1202148138073
>> Request Headers
>> Host     localhost:9447
>> User-Agent     Mozilla/5.0 (Windows; U; Windows NT 5.1; de;
>> rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
>> Accept
>> text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
>>
>> Accept-Language     de,en;q=0.8,en-us;q=0.5,de-de;q=0.3
>> Accept-Encoding     gzip,deflate
>> Accept-Charset     ISO-8859-1,utf-8;q=0.7,*;q=0.7
>> Keep-Alive     300
>> Connection     keep-alive
>> Content-Type     text/xml
>> SOAPAction     login
>> Referer     https://localhost:9447/esb/
>> Content-Length     657
>> Cookie     JSESSIONID=2348EA0D621D9E0997D90D07EE2EF932
>> X-lori-time-1     1202148138053
>> Pragma     no-cache
>> Cache-Control     no-cach
>>
>>
>> *Request:*
>>
>> <?xml version="1.0" encoding="UTF-8"?> <soapenv:Envelope
>> xmlns:soapenv="http://schemas.xmlsoap.org/soap
>>
>> /envelope/"> <soapenv:Header
>> xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">
>> <wsa:To>https
>>
>> ://localhost:9447/esb/soap/LoginAdmin/login</wsa:To>
>> <wsa:Action>login</wsa:Action> <wsa:ReplyTo> <wsa
>>
>> :Address>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:Address>
>> </wsa:ReplyTo
>>
>>> <wsa:MessageID>uuid:BABE23A9BE85EA7AE011327368520801</wsa:MessageID>
>>> </soapenv:Header> <soapenv:Body
>>
>>>  <ns1:login  xmlns:ns1="http://org.apache.axis2/xsd">
>>
>> <arg0>admin</arg0>
>>
>> <arg1>admin</arg1>
>>
>> </ns1:login>
>>
>> </soapenv:Body> </soapenv:Envelope>
>>
>> *Response:*
>>
>> --MIMEBoundaryurn_uuid_1FBBB5D851EFDB4D6F1202148138496
>>
>> Content-Type: application/xop+xml; charset=UTF-8; type="text/xml"
>>
>> Content-Transfer-Encoding: binary
>>
>> Content-ID: <0.urn:uuid:[hidden email]>
>>
>> <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope
>> xmlns:soapenv="http://schemas.xmlsoap.org/soap
>>
>> /envelope/"
>> xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"><soapenv:Header><wsa:To>http
>>
>>
>> ://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To><wsa:MessageID>urn:uuid:1FBBB5D851EFDB4D6F1202148138495
>>
>>
>> </wsa:MessageID><wsa:Action>urn:loginResponse</wsa:Action><wsa:RelatesTo>uuid:BABE23A9BE85EA7AE011327368520801
>>
>>
>> </wsa:RelatesTo></soapenv:Header><soapenv:Body><ns:loginResponse
>> xmlns:ns="http://org.apache.axis2/xsd"
>>
>>> <return>true</return></ns:loginResponse></soapenv:Body></soapenv:Envelope>
>>>
>>
>> --MIMEBoundaryurn_uuid_1FBBB5D851EFDB4D6F1202148138496--
>>
>>
>> In my eyes, it looks fine... but Javascript cannot access the
>> return-tag...
>> I hope, this helps.
>> Thanks,
>> Jens
>>
>>
>>
>> Ruwan Linton schrieb:
>>> Hi Jens,
>>>
>>> It seems like a Java Script error in the console, because the log
>>> says that user admin has logged in to the system :-( .
>>>
>>> BTW: I hope you have used the username admin with password admin. Is
>>> this first time you logged in to ESB?
>>>
>>> Thanks,
>>> Ruwan
>>>
>>> Jens Goldhammer wrote:
>>>> Hello,
>>>>
>>>> After starting the esb 1.6 I want to login into the admin console.
>>>> I press the send button, but nothing happens in the browser.
>>>> Is this problem known? I have seen no JIRA issue...
>>>>
>>>> log-file of esb is attached.
>>>>
>>>> environemnt:
>>>> Windows XP SP 2
>>>> Browser used are:
>>>> firefox 2.0.x (latest)
>>>> firefox 3b2
>>>> IE v. 7
>>>> I have set JAVA_HOME to jdk 1.5.
>>>>
>>>>
>>>>
>>>>
>>>> ------------------------------------------------------------------------
>>>>
>>>>
>>>> _______________________________________________
>>>> Esb-java-user mailing list
>>>> [hidden email]
>>>> http://wso2.org/cgi-bin/mailman/listinfo/esb-java-user
>>>>  
>>>
>>
>

_______________________________________________
Esb-java-user mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/esb-java-user
Reply | Threaded
Open this post in threaded view
|

Re: [Fwd: Re: login into esb v.1.6 failed]

Ruwan Linton-3
Jens,

I think you have accidentally changed a js file or an XSLT file so that
the UI framework fails to load properly.

Any way nice to hear that you got it working :-)

Thanks,
Ruwan

Jens Goldhammer wrote:

> FYI
>
> ------------------------------------------------------------------------
>
> Subject:
> Re: [esb-java-user] login into esb v.1.6 failed
> From:
> Jens Goldhammer <[hidden email]>
> Date:
> Mon, 04 Feb 2008 19:32:56 +0100
> To:
> Ruwan Linton <[hidden email]>
>
> To:
> Ruwan Linton <[hidden email]>
>
>
> Hello Ruwan,
>
> I have tested it with 4 different browsers (firefox2 and 3b2, internet
> explorer 7, opera 9.25)!
> The alert works in all browsers, but the login does not work :-((
>
> I have unzipped the distribution again and start the esb.
> Wow, now it works!!
>
> The difference to my previous instance of the esb is that I haven´t
> change the ports.
> in axis2.xml:
> change port for http from 8080 to 8280
>
> in server.xml:
> change port for adminconsole from 9443 to 9447
>
> I have changed the prots also with the new unzipped esb, but I still
> works. I don´t understand that!!
> Do you have any idea?
> Jens
>
>
> Ruwan Linton schrieb:
>> Jens,
>>
>> It seems something wrong with the browser, could you please try after
>> restarting the browser, (You need to enable Java Script)
>>
>> You could paste the following line on the navigation bar of firefox
>> and see whether java script is working properly. If there is an alert
>> saying "test" it is working???
>>
>> javascript:alert("test");
>>
>> Thanks,
>> Ruwan
>>
>> Jens Goldhammer wrote:
>>> Hello Ruwan,
>>> I have debugged the javascript function with the fireBug-extension
>>> (firefox)
>>>
>>> *Header*
>>>
>>> Response Headers
>>> Server     Apache-Coyote/1.1
>>> Content-Type     multipart/related;
>>> boundary=MIMEBoundaryurn_uuid_1FBBB5D851EFDB4D6F1202148138496;
>>> type="application/xop+xml";
>>> start="0.urn:uuid:[hidden email]";
>>> start-info="text/xml"
>>> Transfer-Encoding     chunked
>>> Date     Mon, 04 Feb 2008 18:02:18 GMT
>>> X-lori-time-2     1202148138073
>>> Request Headers
>>> Host     localhost:9447
>>> User-Agent     Mozilla/5.0 (Windows; U; Windows NT 5.1; de;
>>> rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
>>> Accept
>>> text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
>>>
>>> Accept-Language     de,en;q=0.8,en-us;q=0.5,de-de;q=0.3
>>> Accept-Encoding     gzip,deflate
>>> Accept-Charset     ISO-8859-1,utf-8;q=0.7,*;q=0.7
>>> Keep-Alive     300
>>> Connection     keep-alive
>>> Content-Type     text/xml
>>> SOAPAction     login
>>> Referer     https://localhost:9447/esb/
>>> Content-Length     657
>>> Cookie     JSESSIONID=2348EA0D621D9E0997D90D07EE2EF932
>>> X-lori-time-1     1202148138053
>>> Pragma     no-cache
>>> Cache-Control     no-cach
>>>
>>>
>>> *Request:*
>>>
>>> <?xml version="1.0" encoding="UTF-8"?> <soapenv:Envelope
>>> xmlns:soapenv="http://schemas.xmlsoap.org/soap
>>>
>>> /envelope/"> <soapenv:Header
>>> xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">
>>> <wsa:To>https
>>>
>>> ://localhost:9447/esb/soap/LoginAdmin/login</wsa:To>
>>> <wsa:Action>login</wsa:Action> <wsa:ReplyTo> <wsa
>>>
>>> :Address>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:Address>
>>> </wsa:ReplyTo
>>>
>>>> <wsa:MessageID>uuid:BABE23A9BE85EA7AE011327368520801</wsa:MessageID>
>>>> </soapenv:Header> <soapenv:Body
>>>
>>>>  <ns1:login  xmlns:ns1="http://org.apache.axis2/xsd">
>>>
>>> <arg0>admin</arg0>
>>>
>>> <arg1>admin</arg1>
>>>
>>> </ns1:login>
>>>
>>> </soapenv:Body> </soapenv:Envelope>
>>>
>>> *Response:*
>>>
>>> --MIMEBoundaryurn_uuid_1FBBB5D851EFDB4D6F1202148138496
>>>
>>> Content-Type: application/xop+xml; charset=UTF-8; type="text/xml"
>>>
>>> Content-Transfer-Encoding: binary
>>>
>>> Content-ID: <0.urn:uuid:[hidden email]>
>>>
>>> <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope
>>> xmlns:soapenv="http://schemas.xmlsoap.org/soap
>>>
>>> /envelope/"
>>> xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"><soapenv:Header><wsa:To>http
>>>
>>>
>>> ://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To><wsa:MessageID>urn:uuid:1FBBB5D851EFDB4D6F1202148138495
>>>
>>>
>>> </wsa:MessageID><wsa:Action>urn:loginResponse</wsa:Action><wsa:RelatesTo>uuid:BABE23A9BE85EA7AE011327368520801
>>>
>>>
>>> </wsa:RelatesTo></soapenv:Header><soapenv:Body><ns:loginResponse
>>> xmlns:ns="http://org.apache.axis2/xsd"
>>>
>>>> <return>true</return></ns:loginResponse></soapenv:Body></soapenv:Envelope>
>>>>
>>>
>>> --MIMEBoundaryurn_uuid_1FBBB5D851EFDB4D6F1202148138496--
>>>
>>>
>>> In my eyes, it looks fine... but Javascript cannot access the
>>> return-tag...
>>> I hope, this helps.
>>> Thanks,
>>> Jens
>>>
>>>
>>>
>>> Ruwan Linton schrieb:
>>>> Hi Jens,
>>>>
>>>> It seems like a Java Script error in the console, because the log
>>>> says that user admin has logged in to the system :-( .
>>>>
>>>> BTW: I hope you have used the username admin with password admin.
>>>> Is this first time you logged in to ESB?
>>>>
>>>> Thanks,
>>>> Ruwan
>>>>
>>>> Jens Goldhammer wrote:
>>>>> Hello,
>>>>>
>>>>> After starting the esb 1.6 I want to login into the admin console.
>>>>> I press the send button, but nothing happens in the browser.
>>>>> Is this problem known? I have seen no JIRA issue...
>>>>>
>>>>> log-file of esb is attached.
>>>>>
>>>>> environemnt:
>>>>> Windows XP SP 2
>>>>> Browser used are:
>>>>> firefox 2.0.x (latest)
>>>>> firefox 3b2
>>>>> IE v. 7
>>>>> I have set JAVA_HOME to jdk 1.5.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> ------------------------------------------------------------------------
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Esb-java-user mailing list
>>>>> [hidden email]
>>>>> http://wso2.org/cgi-bin/mailman/listinfo/esb-java-user
>>>>>  
>>>>
>>>
>>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Esb-java-user mailing list
> [hidden email]
> http://wso2.org/cgi-bin/mailman/listinfo/esb-java-user
>  


_______________________________________________
Esb-java-user mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/esb-java-user