Problem in authentication

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem in authentication

Lipsa Pradhan
Hello

I am using Enterprise Integrator. I want to authorise customised users, using authentication service to have access tokens. I had tried "proxy service" method for this. But it isn't working.

How can I do this?


I'm getting this while firing the proxy service.

<soapenv:Fault xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope" xmlns:axis2ns7="http://www.w3.org/2003/05/soap-envelope">
  <soapenv:Code>
  <soapenv:Value>axis2ns7:Sender</soapenv:Value>
  <soapenv:Subcode>
    <soapenv:Value xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">wsse:InvalidSecurity</soapenv:Value>
  </soapenv:Subcode>
</soapenv:Code>
<soapenv:Reason>
  <soapenv:Text xml:lang="en-US">Expected transport is "https" but incoming transport found : "http" </soapenv:Text>
</soapenv:Reason>
<soapenv:Detail/>
</soapenv:Fault>


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem in authentication

Vinod Kavinda
Hi Lipsa,
Your client is sending HTTP requests while the proxy service is configured to only accept HTTPS requests. Either enable http also with proxy header something like this,
<proxy name="LBProxy" transports="https http" startOnLoad="true">
 or send HTTPS requests from the client.

Regards,
Vinod

On Mon, Jun 19, 2017 at 5:04 PM, Lipsa Pradhan <[hidden email]> wrote:
Hello

I am using Enterprise Integrator. I want to authorise customised users, using authentication service to have access tokens. I had tried "proxy service" method for this. But it isn't working.

How can I do this?


I'm getting this while firing the proxy service.

<soapenv:Fault xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope" xmlns:axis2ns7="http://www.w3.org/2003/05/soap-envelope">
  <soapenv:Code>
  <soapenv:Value>axis2ns7:Sender</soapenv:Value>
  <soapenv:Subcode>
    <soapenv:Value xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">wsse:InvalidSecurity</soapenv:Value>
  </soapenv:Subcode>
</soapenv:Code>
<soapenv:Reason>
  <soapenv:Text xml:lang="en-US">Expected transport is "https" but incoming transport found : "http" </soapenv:Text>
</soapenv:Reason>
<soapenv:Detail/>
</soapenv:Fault>


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev




--
Vinod Kavinda
Senior Software Engineer 
Mobile : <a href="tel:%2B94%20%280%29%20712%20415544" value="+94773451194" style="color:rgb(17,85,204)" target="_blank">+94 (0) 712 415544
http://wso2.com/signature


_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Loading...