UserIdentityManagementAdmin service does not return correct set of challenge questions

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

UserIdentityManagementAdmin service does not return correct set of challenge questions

Rajith Roshan
Hi Devs,

When I add a challenge question to existing challenge set ot create new challenge question set from IS 5.3.0 carbon console, and when I invoke the "getAllChallengeQuestions" operation in
UserIdentityManagementAdminService, it  returns the only old set of challenge question. The newly added ones are not visible.

And also , when I add a new question using the "setChallengeQuestions" in admin service, its get added, and I could not see this newly added question in carbon console as well. And also If I invoke the "getAllChallengeQuestions" method after adding a challenge question, it only shows me the newly added one only.

Your inputs regarding this is highly appreciated. 

Thanks!
Rajith

--
Rajith Roshan
Senior Software Engineer, WSO2 Inc.
Mobile: +94-717-064-214

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: UserIdentityManagementAdmin service does not return correct set of challenge questions

Farasath Ahamed


On Tuesday, July 17, 2018, Rajith Roshan <[hidden email]> wrote:
Hi Devs,

When I add a challenge question to existing challenge set ot create new challenge question set from IS 5.3.0 carbon console, and when I invoke the "getAllChallengeQuestions" operation in
UserIdentityManagementAdminService, it  returns the only old set of challenge question. The newly added ones are not visible.

In our new implementation(from IS 5.3.0), Challenge question related operations are done using ChallengeQuestionManagementAdminService[1]



And also , when I add a new question using the "setChallengeQuestions" in admin service, its get added, and I could not see this newly added question in carbon console as well. And also If I invoke the "getAllChallengeQuestions" method after adding a challenge question, it only shows me the newly added one only.

Your inputs regarding this is highly appreciated. 

Thanks!
Rajith

--
Rajith Roshan
Senior Software Engineer, WSO2 Inc.
Mobile: +94-717-064-214


--
Farasath Ahamed
Senior Software Engineer, WSO2 Inc.; http://wso2.com
Mobile: <a href="tel:%2B94777603866" value="+94713149860" style="font-size:12.8px;color:rgb(17,85,204)" target="_blank">+94777603866
Twitter: @farazath619






_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: UserIdentityManagementAdmin service does not return correct set of challenge questions

Rajith Roshan
Thanks Farasath !!

On Mon, Jul 16, 2018 at 12:52 PM Farasath Ahamed <[hidden email]> wrote:


On Tuesday, July 17, 2018, Rajith Roshan <[hidden email]> wrote:
Hi Devs,

When I add a challenge question to existing challenge set ot create new challenge question set from IS 5.3.0 carbon console, and when I invoke the "getAllChallengeQuestions" operation in
UserIdentityManagementAdminService, it  returns the only old set of challenge question. The newly added ones are not visible.

In our new implementation(from IS 5.3.0), Challenge question related operations are done using ChallengeQuestionManagementAdminService[1]



And also , when I add a new question using the "setChallengeQuestions" in admin service, its get added, and I could not see this newly added question in carbon console as well. And also If I invoke the "getAllChallengeQuestions" method after adding a challenge question, it only shows me the newly added one only.

Your inputs regarding this is highly appreciated. 

Thanks!
Rajith

--
Rajith Roshan
Senior Software Engineer, WSO2 Inc.
Mobile: +94-717-064-214


--
Farasath Ahamed
Senior Software Engineer, WSO2 Inc.; http://wso2.com
Mobile: <a href="tel:%2B94777603866" value="+94713149860" style="font-size:12.8px;color:rgb(17,85,204)" target="_blank">+94777603866
Twitter: @farazath619







--
Rajith Roshan
Senior Software Engineer, WSO2 Inc.
Mobile: <a href="javascript:void(0);" value="+94715548430" target="_blank">+94-717-064-214

_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: UserIdentityManagementAdmin service does not return correct set of challenge questions

Isura Karunaratne
In reply to this post by Rajith Roshan
[hidden email] ,

What is the service you used? is that ChallengeQuestionManagementAdminService?
ChallengeQuestionManagementAdminService should be used with the new Identity management implementation. 

Cheers,
Isura.

On Mon, Mar 11, 2019 at 12:11 AM Sajith Ekanayaka <[hidden email]> wrote:
Hi all,

I observed the same in WUM updated 5.3.0 and 5.7.0 packs as well. Is this an expected behavior?

Thanks,
Sajith

On Tue, Jul 17, 2018 at 12:05 AM Rajith Roshan <[hidden email]> wrote:
Hi Devs,

When I add a challenge question to existing challenge set ot create new challenge question set from IS 5.3.0 carbon console, and when I invoke the "getAllChallengeQuestions" operation in
UserIdentityManagementAdminService, it  returns the only old set of challenge question. The newly added ones are not visible.

And also , when I add a new question using the "setChallengeQuestions" in admin service, its get added, and I could not see this newly added question in carbon console as well. And also If I invoke the "getAllChallengeQuestions" method after adding a challenge question, it only shows me the newly added one only.

Your inputs regarding this is highly appreciated. 

Thanks!
Rajith

--
Rajith Roshan
Senior Software Engineer, WSO2 Inc.
Mobile: +94-717-064-214


--
Sajith Ekanayaka
Software Engineer | WSO2

Mobile: +94 714003025
Web: http://wso2.com



--
Isura Dilhara Karunaratne
Associate Technical Lead | WSO2 
lean.enterprise.middleware
Mob : +94 772 254 810




_______________________________________________
Dev mailing list
[hidden email]
http://wso2.org/cgi-bin/mailman/listinfo/dev