[jira] Created: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Created: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

JIRA jira@wso2.org
request to a WSDL via https returns wrong scheme prefix
-------------------------------------------------------

                 Key: WSFPHP-367
                 URL: https://wso2.org/jira/browse/WSFPHP-367
             Project: WSO2 WSF/PHP
          Issue Type: Bug
          Components: WSDL Generation
    Affects Versions: 2.0.0
         Environment: Fedora 8 i386 Linux
            Reporter: Philip Eschenbacher
         Attachments: https_wsdl.patch

when requesting a wsdl via https URL the service destination URL still has a http scheme prefix. correct were the https prefix. Lets have a look to a little example:

https://myservice/?wsdl

returns the following WSDL target:

...
<service name="myservice">
<port name="myserviceSOAPPort_Http" binding="tns:myserviceSOAPBinding">
<soap:address location="http://myservice:443/index.php"/>
</port>
</service>
...

I provide a workaround patch with this ticket. This patch should not be applyed because it does not solve the problem very well. ws_generate_wsdl in wsf.php receives a request url without scheme prefix. so i had to decide by selecting the port number which scheme prefix to set. I think it would be bether to call the ws_generate_wsdl function and provide a valid request URL with scheme prefix like https://hostname/path... and then set this prefix instead of the WS_WSDL_HTTP_ATTR_NAME const.



--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Updated: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

JIRA jira@wso2.org

     [ https://wso2.org/jira/browse/WSFPHP-367?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Philip Eschenbacher updated WSFPHP-367:
---------------------------------------

    Attachment:     (was: https_wsdl.patch)

> request to a WSDL via https returns wrong scheme prefix
> -------------------------------------------------------
>
>                 Key: WSFPHP-367
>                 URL: https://wso2.org/jira/browse/WSFPHP-367
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>          Components: WSDL Generation
>    Affects Versions: 2.0.0
>         Environment: Fedora 8 i386 Linux
>            Reporter: Philip Eschenbacher
>         Attachments: https_wsdl.patch
>
>
> when requesting a wsdl via https URL the service destination URL still has a http scheme prefix. correct were the https prefix. Lets have a look to a little example:
> https://myservice/?wsdl
> returns the following WSDL target:
> ...
> <service name="myservice">
> <port name="myserviceSOAPPort_Http" binding="tns:myserviceSOAPBinding">
> <soap:address location="http://myservice:443/index.php"/>
> </port>
> </service>
> ...
> I provide a workaround patch with this ticket. This patch should not be applyed because it does not solve the problem very well. ws_generate_wsdl in wsf.php receives a request url without scheme prefix. so i had to decide by selecting the port number which scheme prefix to set. I think it would be bether to call the ws_generate_wsdl function and provide a valid request URL with scheme prefix like https://hostname/path... and then set this prefix instead of the WS_WSDL_HTTP_ATTR_NAME const.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Updated: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

     [ https://wso2.org/jira/browse/WSFPHP-367?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Philip Eschenbacher updated WSFPHP-367:
---------------------------------------

    Attachment: https_wsdl.patch

> request to a WSDL via https returns wrong scheme prefix
> -------------------------------------------------------
>
>                 Key: WSFPHP-367
>                 URL: https://wso2.org/jira/browse/WSFPHP-367
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>          Components: WSDL Generation
>    Affects Versions: 2.0.0
>         Environment: Fedora 8 i386 Linux
>            Reporter: Philip Eschenbacher
>         Attachments: https_wsdl.patch
>
>
> when requesting a wsdl via https URL the service destination URL still has a http scheme prefix. correct were the https prefix. Lets have a look to a little example:
> https://myservice/?wsdl
> returns the following WSDL target:
> ...
> <service name="myservice">
> <port name="myserviceSOAPPort_Http" binding="tns:myserviceSOAPBinding">
> <soap:address location="http://myservice:443/index.php"/>
> </port>
> </service>
> ...
> I provide a workaround patch with this ticket. This patch should not be applyed because it does not solve the problem very well. ws_generate_wsdl in wsf.php receives a request url without scheme prefix. so i had to decide by selecting the port number which scheme prefix to set. I think it would be bether to call the ws_generate_wsdl function and provide a valid request URL with scheme prefix like https://hostname/path... and then set this prefix instead of the WS_WSDL_HTTP_ATTR_NAME const.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-367?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28368#action_28368 ]

Mike Reid commented on WSFPHP-367:
----------------------------------

Thank you so much for providing this patch, Philip. I can confirm that this patch works as intended, and it fixed many issues we had been running into working with WSF/PHP secure services over SSL, specific with other clients, such as native PHP SoapClient (NOT using wsf/php WSClient). We have patched all production and development instances with Philip's modifications and everything has been running great ever since. (Environment: Linux x86_64 CentOS 5.2) I just checked the most recent Nightly Build, which seems to be dated back to Apr 8, 2009...Are there any plans to incorporate this patch into the next WSF/PHP release? I would highly recommend it!

> request to a WSDL via https returns wrong scheme prefix
> -------------------------------------------------------
>
>                 Key: WSFPHP-367
>                 URL: https://wso2.org/jira/browse/WSFPHP-367
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>          Components: WSDL Generation
>    Affects Versions: 2.0.0
>         Environment: Fedora 8 i386 Linux
>            Reporter: Philip Eschenbacher
>         Attachments: https_wsdl.patch
>
>
> when requesting a wsdl via https URL the service destination URL still has a http scheme prefix. correct were the https prefix. Lets have a look to a little example:
> https://myservice/?wsdl
> returns the following WSDL target:
> ...
> <service name="myservice">
> <port name="myserviceSOAPPort_Http" binding="tns:myserviceSOAPBinding">
> <soap:address location="http://myservice:443/index.php"/>
> </port>
> </service>
> ...
> I provide a workaround patch with this ticket. This patch should not be applyed because it does not solve the problem very well. ws_generate_wsdl in wsf.php receives a request url without scheme prefix. so i had to decide by selecting the port number which scheme prefix to set. I think it would be bether to call the ws_generate_wsdl function and provide a valid request URL with scheme prefix like https://hostname/path... and then set this prefix instead of the WS_WSDL_HTTP_ATTR_NAME const.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Assigned: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

     [ https://wso2.org/jira/browse/WSFPHP-367?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Nandika Jayawardana reassigned WSFPHP-367:
------------------------------------------

    Assignee: Nandika Jayawardana

> request to a WSDL via https returns wrong scheme prefix
> -------------------------------------------------------
>
>                 Key: WSFPHP-367
>                 URL: https://wso2.org/jira/browse/WSFPHP-367
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>          Components: WSDL Generation
>    Affects Versions: 2.0.0
>         Environment: Fedora 8 i386 Linux
>            Reporter: Philip Eschenbacher
>            Assignee: Nandika Jayawardana
>         Attachments: https_wsdl.patch
>
>
> when requesting a wsdl via https URL the service destination URL still has a http scheme prefix. correct were the https prefix. Lets have a look to a little example:
> https://myservice/?wsdl
> returns the following WSDL target:
> ...
> <service name="myservice">
> <port name="myserviceSOAPPort_Http" binding="tns:myserviceSOAPBinding">
> <soap:address location="http://myservice:443/index.php"/>
> </port>
> </service>
> ...
> I provide a workaround patch with this ticket. This patch should not be applyed because it does not solve the problem very well. ws_generate_wsdl in wsf.php receives a request url without scheme prefix. so i had to decide by selecting the port number which scheme prefix to set. I think it would be bether to call the ws_generate_wsdl function and provide a valid request URL with scheme prefix like https://hostname/path... and then set this prefix instead of the WS_WSDL_HTTP_ATTR_NAME const.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Resolved: (WSFPHP-367) request to a WSDL via https returns wrong scheme prefix

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

     [ https://wso2.org/jira/browse/WSFPHP-367?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Nandika Jayawardana resolved WSFPHP-367.
----------------------------------------

    Fix Version/s: Current (nightly)
       Resolution: Fixed

patch applied

> request to a WSDL via https returns wrong scheme prefix
> -------------------------------------------------------
>
>                 Key: WSFPHP-367
>                 URL: https://wso2.org/jira/browse/WSFPHP-367
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>          Components: WSDL Generation
>    Affects Versions: 2.0.0
>         Environment: Fedora 8 i386 Linux
>            Reporter: Philip Eschenbacher
>            Assignee: Nandika Jayawardana
>             Fix For: Current (nightly)
>
>         Attachments: https_wsdl.patch
>
>
> when requesting a wsdl via https URL the service destination URL still has a http scheme prefix. correct were the https prefix. Lets have a look to a little example:
> https://myservice/?wsdl
> returns the following WSDL target:
> ...
> <service name="myservice">
> <port name="myserviceSOAPPort_Http" binding="tns:myserviceSOAPBinding">
> <soap:address location="http://myservice:443/index.php"/>
> </port>
> </service>
> ...
> I provide a workaround patch with this ticket. This patch should not be applyed because it does not solve the problem very well. ws_generate_wsdl in wsf.php receives a request url without scheme prefix. so i had to decide by selecting the port number which scheme prefix to set. I think it would be bether to call the ws_generate_wsdl function and provide a valid request URL with scheme prefix like https://hostname/path... and then set this prefix instead of the WS_WSDL_HTTP_ATTR_NAME const.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Loading...