[jira] Created: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Created: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
-----------------------------------------------------------------------------------------------------

                 Key: WSFPHP-400
                 URL: https://wso2.org/jira/browse/WSFPHP-400
             Project: WSO2 WSF/PHP
          Issue Type: Bug
    Affects Versions: 2.0.0
         Environment: CentOS 5.2 / Linux x86_64
            Reporter: Mike Reid
            Priority: Highest


All,

WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php

I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3

In addition, here are the files containing references to the now deprecated functions:

ereg() - ./scripts/wsdl2php/wsf_utils.php
split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php

Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?

Kind Regards,

Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28589#action_28589 ]

Mike Reid commented on WSFPHP-400:
----------------------------------

I believe I was mistaken. For clarification, WSF/PHP still does not work in PHP 5.3.0, however it seems the functions I listed above are only deprecated in PHP 5.3.0 for FUTURE removal. This means that they should still be valid functions and would still exist (for now). It probably would only become an issue if the new E_DEPRECATED error level was being used in error_reporting().

However, there seems to be something else related to WSF/PHP's PHP 5.3.0 incompatibility. Has anyone else successfully tested WSF/PHP 2.0.0 on a PHP 5.3.0 build?

> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28608#action_28608 ]

Mike Reid commented on WSFPHP-400:
----------------------------------

Does anyone else receive the following error when trying to build WSF/PHP 2.0.0 from source on Unix when using PHP 5.3.0?

wso2-wsf-php-src-2.0.0/src/wsf.c:131: error: duplicate 'static'
make[2]: *** [wsf.lo] Error 1
make[2]: Leaving directory `wso2-wsf-php-src-2.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `wso2-wsf-php-src-2.0.0'
make: *** [all] Error 2

I found two related threads in the forums:

http://wso2.org/forum/thread/5247
http://wso2.org/forum/thread/5707

...I run into the exact same errors when PHP 5.3.0 is installed. If I downgrade to 5.2.10, the build completes without error.

NOTE: I have even tried building from the latest nightly build, but the error is still present. Nandika claims to have make the fix in SVN, so perhaps this is a better source than the nightly build?

Will anyone from the WSO2 comment on the PHP 5.3 issues? Is there a roadmap / intended date of supporting this newer build?

> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28614#action_28614 ]

Nandika Jayawardana commented on WSFPHP-400:
--------------------------------------------

I will look into this issue and fix it on the current svn trunk. Then interested users will be able to get the pack from the nightly build.



> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28618#action_28618 ]

Nandika Jayawardana commented on WSFPHP-400:
--------------------------------------------

I only encounter one compilation issue while compiling on windows and it is fixed on the current svn trunk now. Also the above mentioned functions were replaced with compatible functions.

> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28619#action_28619 ]

Mike Reid commented on WSFPHP-400:
----------------------------------

Thank you, Nandika. I have just downloaded from the SVN, the nightly build apparently hasn't been rebuilt in many months. I will let you know how it goes! Also, is there anyway to determine in the SVN if the following patch has been applied to the source? https://www.wso2.org/jira/browse/WSFPHP-367

> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Issue Comment Edited: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28619#action_28619 ]

Mike Reid edited comment on WSFPHP-400 at 8/11/09 9:40 PM:
-----------------------------------------------------------

Thank you, Nandika. I have just downloaded from the SVN, the nightly build apparently hasn't been rebuilt in many months. I will let you know how it goes!

Also, is there anyway to determine in the SVN if the following patch has been applied to the source? https://www.wso2.org/jira/browse/WSFPHP-367

UPDATE:

When I try downloading from the SVN it seems my local "wsf_c" directory is incomplete? The wso2-wsf-php-src-2.0.0/ from wso2.org is 141MB (uncompressed), and my export from this SVN copy is only 5.9MB (uncompressed).

Not sure how to fix this to test from SVN?

      was (Author: pixelchutes):
    Thank you, Nandika. I have just downloaded from the SVN, the nightly build apparently hasn't been rebuilt in many months. I will let you know how it goes! Also, is there anyway to determine in the SVN if the following patch has been applied to the source? https://www.wso2.org/jira/browse/WSFPHP-367
 

> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Assigned: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

     [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Nandika Jayawardana reassigned WSFPHP-400:
------------------------------------------

    Assignee: Nandika Jayawardana

> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Assignee: Nandika Jayawardana
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Commented: (WSFPHP-400) PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+

JIRA jira@wso2.org
In reply to this post by JIRA jira@wso2.org

    [ https://wso2.org/jira/browse/WSFPHP-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=28620#action_28620 ]

Nandika Jayawardana commented on WSFPHP-400:
--------------------------------------------

The niglity  build seem to have an isssue and will be fixed. Will look in to it.


> PHP 5.3.0 Compatability Issues - WSF/PHP 2.0.0 errors and does not not function correctly on PHP 5.3+
> -----------------------------------------------------------------------------------------------------
>
>                 Key: WSFPHP-400
>                 URL: https://wso2.org/jira/browse/WSFPHP-400
>             Project: WSO2 WSF/PHP
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: CentOS 5.2 / Linux x86_64
>            Reporter: Mike Reid
>            Assignee: Nandika Jayawardana
>            Priority: Highest
>
> All,
> WSF/PHP 2.0.0 is no longer compatible with PHP 5.3.0 :( Here is the list of the functions that were deprecated with this new release: http://php.net/manual/en/migration53.deprecated.php
> I have built from source and can confirm that WSF/PHP will need to be updated to support PHP 5.3
> In addition, here are the files containing references to the now deprecated functions:
> ereg() - ./scripts/wsdl2php/wsf_utils.php
> split() - ./scripts/dynamic_invocation/wsf_wsdl_util.php
> Updating these files alone does not solve this issue. Are there currently any efforts underway to restore functionality for this new PHP release?
> Kind Regards,
> Mike

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Loading...