[jira] Created: (WSFPHP-402) Error when using Java client and https request

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] Created: (WSFPHP-402) Error when using Java client and https request

JIRA jira@wso2.org
Error when using Java client and https request
----------------------------------------------

                 Key: WSFPHP-402
                 URL: https://wso2.org/jira/browse/WSFPHP-402
             Project: WSO2 WSF/PHP
          Issue Type: Bug
          Components: WSDL Mode
    Affects Versions: 2.0.0
         Environment: Client:
   Java 1.5.0_20
   Metro webservice library (v 1.5)
Server:
  Linux  2.6.18-53.1.21.el5PAE
  wso2 v2.0
            Reporter: John Thorhauer
         Attachments: wsf-wsdl-https.patch

I have manually applied the patch from bug WSFPHP-367.  I am connecting the the webservice using Java/Metro and I get an error on the server side as follows when trying to call an operation:
  ERROR:file_get_contents(http://jthor.yakabod.net:443/ws/BaseObjectService-1_0?wsdl) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! &lt;!DOCTYPE HTML PUBLIC &quot;-//IETF//DTD HTML 2.0//EN&quot;&gt;  FILE:wsf_wsdl.php LINE:176 STACK:#0  WSErrorHandler::handle(2, file_get_contents(http://jthor.yakabod.net:443/ws/BaseObjectService-1_0?wsdl) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! &lt;!DOCTYPE HTML PUBLIC &quot;-//IETF//DTD HTML 2.0//EN&quot;&gt; , wsf_wsdl.php, 176, Array ([wsdl_url] => http://jthor.yakabod.net:443/ws/BaseObjectService-1_0?wsdl,[user_parameters] => Array ([wsdl] => http://jthor.yakabod.net:443/ws/BaseObjectService-1_0?wsdl,[serviceName] => BaseObjectService-1_0),[username] => ,[password] => ,[password_type] => ,[options] => ,[http_response_header] => Array

The problem appears to be that somewhere, not sure where, the wsdl url is getting set to http://jthor.yakabod.net:443/ (note there is no https).  It seems that this call is happening in part of the C code somewhere.  I have attached the patch that fixed this for me.  Although this may be a problem at a deeper level than where I fixed it at.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://wso2.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
Wsf-c-dev mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-c-dev
Loading...