wso2 and php 5.3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

wso2 and php 5.3

Fabian Panthen

Hello,

We were able to build wso2 2.1.0 with php 5.3 but could not at all run it with apache 2.2 as a module.
Running as FastCGI it did work eventually but led reliably to segmentation faults after a short while.
Downgrading to php 5.2 did solve the problem but is not even a mid term solution.

Is there a roadmap for a tried and tested 5.3 compatible release?

Kind regards

Fabian
_______________________________________________
Wsf-php-user mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-php-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: wso2 and php 5.3

Nandika Jayawardana
We tested the 2.1.0 release with PHP 5.3.0 version. There could be issues with later versions of php since some of the internals seems to have changed.

Regards
Nandika

On Mon, Jan 10, 2011 at 11:38 PM, Fabian Panthen <[hidden email]> wrote:

Hello,

We were able to build wso2 2.1.0 with php 5.3 but could not at all run it with apache 2.2 as a module.
Running as FastCGI it did work eventually but led reliably to segmentation faults after a short while.
Downgrading to php 5.2 did solve the problem but is not even a mid term solution.

Is there a roadmap for a tried and tested 5.3 compatible release?

Kind regards

Fabian
_______________________________________________
Wsf-php-user mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-php-user



--
Nandika Jayawardana
Technical Lead and Project Manager,
WSO2 Inc ; http://wso2.com
lean.enterprise.middleware


_______________________________________________
Wsf-php-user mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-php-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: wso2 and php 5.3

Fabian Panthen

which server configuration did you test this with?
I do not seem to be the only one who seems to have problems with php 5.3:





As i wrote earlier, at least with apache 2.2 and php 5.3 it was not possible to run wsf/php at all.
Only a downgrade to php 5.2 saved us from segmentation faults and subsequent server crashes.

Kind regards

Fabian

Am 11.01.2011 um 03:07 schrieb Nandika Jayawardana:

We tested the 2.1.0 release with PHP 5.3.0 version. There could be issues with later versions of php since some of the internals seems to have changed.

Regards
Nandika

On Mon, Jan 10, 2011 at 11:38 PM, Fabian Panthen <[hidden email]> wrote:

Hello,

We were able to build wso2 2.1.0 with php 5.3 but could not at all run it with apache 2.2 as a module.
Running as FastCGI it did work eventually but led reliably to segmentation faults after a short while.
Downgrading to php 5.2 did solve the problem but is not even a mid term solution.

Is there a roadmap for a tried and tested 5.3 compatible release?

Kind regards

Fabian
_______________________________________________
Wsf-php-user mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-php-user



--
Nandika Jayawardana
Technical Lead and Project Manager,
WSO2 Inc ; http://wso2.com
lean.enterprise.middleware

_______________________________________________
Wsf-php-user mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-php-user


_______________________________________________
Wsf-php-user mailing list
[hidden email]
https://wso2.org/cgi-bin/mailman/listinfo/wsf-php-user
Loading...